Re: ERROR: could not open relation with OID 49152

Поиск
Список
Период
Сортировка
Искать
От
Alvaro Herrera
Тема
Re: ERROR: could not open relation with OID 49152
Дата
Msg-id
20080722002319.GL5842@alvh.no-ip.org
Ответ на
Список
Дерево обсуждения
ERROR: could not open relation with OID 49152 "Scott Marlowe" <scott.marlowe@gmail.com>
Re: ERROR: could not open relation with OID 49152 Tom Lane <tgl@sss.pgh.pa.us>
Re: ERROR: could not open relation with OID 49152 "Scott Marlowe" <scott.marlowe@gmail.com>
Re: ERROR: could not open relation with OID 49152 Alvaro Herrera <alvherre@commandprompt.com>
Scott Marlowe escribió:
> OK, I'm getting the above error on one of my fairly new 8.3 production
> databases.  It happens when I run a query to see the size of my
> tables.
> 
> SELECT pg_relation_size(c.relfilenode), n.nspname AS schemaname,
> c.relname AS tablename, pg_get_userbyid(c.relowner) AS tableowner,
> t.spcname AS tablespace, c.relhasindex AS hasindexes, c.relhasrules AS
> hasrules, c.reltriggers > 0 AS hastriggers
>    FROM pg_class c
>    LEFT JOIN pg_namespace n ON n.oid = c.relnamespace
>    LEFT JOIN pg_tablespace t ON t.oid = c.reltablespace
>   WHERE n.nspname = 'public';
> ERROR:  could not open relation with OID 49152

Try pg_relation_size(c.oid) instead.

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
В списке pgsql-general по дате отправления
От: Tom Lane
Дата:
От: Scott Marlowe
Дата:
FAQ