Re: Propose a new function - list_is_empty

Поиск
Список
Период
Сортировка
От Tom Lane
Тема Re: Propose a new function - list_is_empty
Дата
Msg-id 1004027.1660613276@sss.pgh.pa.us
обсуждение исходный текст
Ответ на Propose a new function - list_is_empty  (Peter Smith <smithpb2250@gmail.com>)
Ответы Re: Propose a new function - list_is_empty  (Peter Smith <smithpb2250@gmail.com>)
Re: Propose a new function - list_is_empty  (Peter Smith <smithpb2250@gmail.com>)
Re: Propose a new function - list_is_empty  (Robert Haas <robertmhaas@gmail.com>)
Список pgsql-hackers
Peter Smith <smithpb2250@gmail.com> writes:
> During a recent code review I was going to suggest that some new code
> would be more readable if the following:
> if (list_length(alist) == 0) ...

> was replaced with:
> if (list_is_empty(alist)) ...

> but then I found that actually no such function exists.

That's because the *correct* way to write it is either "alist == NIL"
or just "!alist".  I don't think we need yet another way to spell
that, and I'm entirely not on board with replacing either of those
idioms.  But if you want to get rid of overcomplicated uses of
list_length() in favor of one of those spellings, have at it.

            regards, tom lane



В списке pgsql-hackers по дате отправления:

Предыдущее
От: Peter Smith
Дата:
Сообщение: Propose a new function - list_is_empty
Следующее
От: Peter Smith
Дата:
Сообщение: Re: Propose a new function - list_is_empty